Raster Service Degraded Performace
Incident Report for Descartes Labs Public
Resolved
Our Raster service is now functioning normally. Please note that due to the location of the data from Sentinel-2 L2A, you may continue to experience latencies when using that product. We will continue to work on improving data access to Sentinel-2 L2A.
Posted Oct 24, 2022 - 09:04 MDT
Monitoring
Monitoring - We deployed a change to raster that should ameliorate the latency issues with Raster. This fix may increase the retries because of increased 503's (service unavailable) responses but should overall increase throughput and typically result in successful retries. We'll keep monitoring our services to verify that this fix improves the overall throughput of our Raster service, even if the Sentinel-2 L2A Catalog Product itself will keep performing with increased latencies.
Posted Oct 20, 2022 - 19:43 MDT
Identified
Our team identified an issue involving slow responses from the Sentinel-2 L2A Catalog product (esa:sentinel-2:l2a:v1) that is causing increased latency when accessing all Catalog products through the Raster service, which underpins the Scenes and Workflows APIs. In some cases, this increased latency is also causing authentication errors as tokens used to authenticate with the platform expire before the operation they are performing can complete. We are working on a solution and will share updates with you as we have them.
Posted Oct 20, 2022 - 11:58 MDT
This incident affected: Platform Services (Raster).